Moving Form Fields | Support Questions | Support Forum

A A A

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Moving Form Fields
March 3, 2019
8:11 pm
Gayle
Member
Members
Forum Posts: 8
Member Since:
March 3, 2019
sp_UserOfflineSmall Offline

Hi everybody,

I just know this is probably already in the forum somewhere but I can't find it. And I also know it is probably something I am doing wrong, but I don't know what. I want to change the position of the fields in the form. I use the dots to shift them around but they don't change on the frontend. I have cleared caches etc. Then when I go back into the Form Fields, they are back where they were in the first place. They just won't stay where I put them. Can anyone advise please?

March 4, 2019
9:13 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 5378
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Gayle,

Thanks for posting. Sorry that you ran into issues with this!

I wasn't able to reproduce this on my test site. However, we are happy to help troubleshoot this issue with you. Can you tell me a bit more?
- What version of WP are you running here?
- What exact version of AWPCP?  (number, please)
- What exact version of any other AWPCP Modules? (number, please)

We should also do a check for theme and plugin conflicts. Theme and plugin conflicts are very common in WordPress, and a conflict test is used to help determine the cause of the issue. Please conduct the test and let me know the results. Here is an article about how to test for theme and plugin conflicts with AWPCP, which may help pinpoint the issue: http://awpcp.com/forum/faq/how.....conflicts/

That will help us troubleshoot the issue a little faster. Please let me know. 

March 4, 2019
5:09 pm
Gayle
Member
Members
Forum Posts: 8
Member Since:
March 3, 2019
sp_UserOfflineSmall Offline

Hi,

Thanks for your reply. I just added the question to the wordpress forum because I forgot it was actually here I first put the question. Too much to keep in mind at the moment.

Both the WP and the AWPCP are the latest. (5.1 and 3.9.5). Everything else about the plugin is working fine; there is just no way to change and save the position of the fields. There's no save button, and each time I leave then return it's back where it started. Before I deactivate all the plugins, can you please tell me if there is meant to be a save button on that page? There is on every other page/section.

March 4, 2019
5:41 pm
Gayle
Member
Members
Forum Posts: 8
Member Since:
March 3, 2019
sp_UserOfflineSmall Offline

Sorry, me again,

It's not really that Form Fields page that is doing it. The website page is actually displaying it differently to that anyway. The fields I selected to show are all there but they are not in the order of the Form Fields (even without changing them). In the admin they are showing "Title, Details, Name, Email, Phone, Regions, Website, Price", but on the website they show as "Title, Website, Name, Email, Phone, Regions, Price, Details". What I really want is "Title, Details, Regions, Price, Name, Email, Phone, Website".

All very confusing, I know, but hopefully you will be able to help me.

March 4, 2019
5:44 pm
Gayle
Member
Members
Forum Posts: 8
Member Since:
March 3, 2019
sp_UserOfflineSmall Offline

Okay, now I'm going crazy. I went out of the Form Fields to check on something else, came back and the fields are showing the same as the website. Sorry, it is that section. I need to be able to save it somehow.

March 4, 2019
6:20 pm
Gayle
Member
Members
Forum Posts: 8
Member Since:
March 3, 2019
sp_UserOfflineSmall Offline

Don't get sick of me, but I thought you would want to know. I had an old version of the plugin 3.9.3 saved in a complete old backup download of another site. I uninstalled 3.9.5 reloaded an sql from before installing it so it cleared everything. I then installed 3.9.3 and the form fields work perfectly (no save button). I am thinking of using the old version until everything is set up then try updating it and see what happens.

March 4, 2019
6:34 pm
Gayle
Member
Members
Forum Posts: 8
Member Since:
March 3, 2019
sp_UserOfflineSmall Offline

Yep, did that. I got everything set up in 3.9.3 until it was the way I wanted, then updated via the admin and everything stayed in place perfectly. There is some sort of glitch in 3.9.5 in the saving of the position of the form fields, but at least the update didn't alter the settings of 3.9.3. I'm happy now.

March 5, 2019
9:09 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 5378
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Gayle,

Thanks for posting your problem-solving process. The version I am using is 3.9.5 and there is no bug causing this as far as I can tell, since my fields save the same and look the same on my test site. Were you able to try a conflict test to see if that produced results? 

If you'd like to update to 3.9.5, which we recommend, we can work on this with you to resolve the problem. Please let me know.

March 5, 2019
12:21 pm
Gayle
Member
Members
Forum Posts: 8
Member Since:
March 3, 2019
sp_UserOfflineSmall Offline

I already did update. That's what I mean. If I start by installing 3.9.3 from an old saved file on my computer, arrange the fields and the settings etc, then update to 3.9.5 everything works great. But when I started just by installing the 3.9.5 from WP via the "Add New" the fields didn't save. Perhaps something went wrong on that first new install or WP sent me a slightly corrupt file, I don't know but it's great now.

March 6, 2019
8:57 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 5378
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Gayle,

Sorry for any confusion here. The conflict test is something you do with the latest version of the plugin installed. You then change to a default WordPress theme, like TwentySeventeen, and turn off all other plugins. The issue you are seeing now should no longer be present at that point. Then, you turn your plugins back on one by one and see when the problem comes back. If it's not another plugin causing the issue, then you switch your theme back to what you are using and see if the problem is back. Then you know what is causing the issue. 

Theme and plugin conflicts are very common in WordPress, and a conflict test is used to help determine the cause of the issue. Here is an article about how to test for theme and plugin conflicts with AWPCP, which may help pinpoint the issue: http://awpcp.com/forum/faq/how.....conflicts/

Please try that and let me know if you run into more issues.

March 7, 2019
3:23 pm
Gayle
Member
Members
Forum Posts: 8
Member Since:
March 3, 2019
sp_UserOfflineSmall Offline

Hi again,

No, there's no confusion. I fixed all the above, thanks. I just have one more difficult question. I really want to use this plugin because I can't find anything better, but I need to be able to allow the members to put POA in the price field. If I simply allow the price as optional, it shows in the frontend as $0 which makes it sound like it's free.

So, in summary, is there a way to change the validation of the price field to allow for text not just numbers?

Thanks.

March 8, 2019
8:57 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 5378
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Gayle,

Thanks for following up here.

This field cannot be changed to include both text and numbers, because price range searches wouldn't work. When you put other strings in the field, the plugin can't do value based ranges.  

However, we do have a workaround for this issue. You can:

1) Turn off the price field under the Form Fields tab (Classifieds > Settings, Form)
2) Buy the Extra Fields Module: https://awpcp.com/downloads/extra-fields-module/
3) Create a field that meets your requirements.

I hope that helps.

Forum Timezone: America/Denver

Most Users Ever Online: 163

Currently Online:
27 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Johnny B: 140

godie: 120

kerdezo: 99

laburke: 94

NAIN KHAN: 93

salvig67: 84

sctpfwape: 75

rude: 72

purplepaula: 72

gery: 71

Member Stats:

Guest Posters: 32

Members: 38189

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 7044

Posts: 31318

Newest Members:

pinillo, Elvin Anthony, Mario, Shosal, solodpsd sd, Corey L, KevEd, IRVAN SYAHPUTRA, Sanjay shastriji, Sanjay shastriji

Moderators: awpcp: 7530, AWPCP Support: 5378, Bobbie Devereux: 0

Administrators: wpengine: 0, awpcp: 300

Skip to toolbar