Classifieds Ads no longer showing up on Facebook | Support Questions | Support Forum

A A A

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Classifieds Ads no longer showing up on Facebook
March 24, 2018
10:53 am
Michael
Member
Members
Forum Posts: 13
Member Since:
October 12, 2016
sp_UserOfflineSmall Offline

It seems that Facebook must have updated their Webpage API or something, because when I hit the diagnostics button now, I am getting a new message (seen below). I also noticed a new Facebook Groups message down on the page for the settings. It used to show a listing of my groups I admin.

Facebook Config Diagnostics
• User Access Token is valid but doesn’t have the permissions required for AWPCP integration (publish_pages, publis_actions and manage_pages).

There are no Facebook groups available for you to select. Please make sure you are connected to the internet and have granted the Facebook application the correct permissions. Click “Diagnostics” if you are in doubt.

 

Wordpress Version: 4.9.4

AWPCP Version: 3.8.3

March 26, 2018
9:07 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 5119
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Michael,

Thanks for contacting me here. Sorry that you ran into issues with this!

Facebook does update things frequently, so that could be the issue here. Can we please get WP admin and FTP credentials to your site to look into this further?

We need the following information to debug the issue:
– A link to this forum thread
– WP admin username
– WP admin password
– WP login URL
– FTP username
– FTP password
– FTP servername/IP address

Contact us with a link to this forum thread and that information here: https://awpcp.com/contact/

March 27, 2018
7:46 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 5119
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Michael,

The developer had a look here, and the current Facebook settings appear to be working on our end. If you would like further assistance with this, please send the information requested above. 

April 4, 2018
12:15 pm
Michael
Member
Members
Forum Posts: 13
Member Since:
October 12, 2016
sp_UserOfflineSmall Offline

Sorry, I haven’t been able to respond, but it seems that Facebook has made serious changes to the Facebook API. I found this article that says what has happened: “Any new Facebook Login Apps create AFTER the beginning of March 2018 now have Use Strict Mode for Redirect URIs and Enforce HTTPS enabled by default and can no longer be disabled.” 

What is the fix for something like this?

References:

https://wp-native-articles.com/blog/news/how-to-fix-facebook-apps-error-cant-load-url-domain-url-isnt-included-apps-domains/

April 4, 2018
12:23 pm
Michael
Member
Members
Forum Posts: 13
Member Since:
October 12, 2016
sp_UserOfflineSmall Offline

When I click on the “obtain an access token from Facebook“, this window appears from Facebook:

URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs.

April 4, 2018
4:56 pm
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 5119
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Michael,

Please contact us with a link to this forum thread so I can get you the solution for this: https://awpcp.com/contact/

April 5, 2018
8:43 pm
Michael
Member
Members
Forum Posts: 13
Member Since:
October 12, 2016
sp_UserOfflineSmall Offline

Ok. I have used the contact form and provided information.

Forum Timezone: America/Denver

Most Users Ever Online: 163

Currently Online:
18 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Johnny B: 140

godie: 120

kerdezo: 99

laburke: 94

NAIN KHAN: 93

salvig67: 84

rude: 72

purplepaula: 72

WAYTOBAYWTB52: 71

gery: 71

Member Stats:

Guest Posters: 30

Members: 37749

Moderators: 2

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 6901

Posts: 30761

Newest Members:

Mandy Janes, KISHORE, Haris, Tien, copy paste, JJ, Kris Hadlock, ejuzaw, ziwibam, martinrolan

Moderators: awpcp: 7530, AWPCP Support: 5119

Administrators: wpengine: 0, awpcp: 298

Skip to toolbar