Cannot get USA, States and Cities/Towns to work - Enable, disable, localize all fail | Support Questions | Support Forum

A A A

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Cannot get USA, States and Cities/Towns to work - Enable, disable, localize all fail
December 1, 2017
9:56 am
Chris
Member
Members
Forum Posts: 9
Member Since:
September 18, 2017
sp_UserOfflineSmall Offline

Hello, 

Can you help me enable ONLY USA (not North America, and not Canada)–Just USA and states and cities/towns (counties?).

I’ve tried Localize and it seems to be localized but I can’t get a list of states in USA–let alone cities/towns in those states.

Thank you in advance for the help.

Chris

December 1, 2017
10:16 am
Chris
Member
Members
Forum Posts: 9
Member Since:
September 18, 2017
sp_UserOfflineSmall Offline

I’m reading this and it is a no go.

https://awpcp.com/forum/faq/regions-module-configuration-tips/

I found a list of the 50 US states and was able to add them as a State/Town (What The Fish? “Town” with the State in the same label? Really?).

Now I want to add cities to each state. So I found a list of cities in Alabama, but when I click Add Regions, then paste the list into the box (each on their own line), And I select City for the Region Type Alabama will not appear in the Region Parent–only North America will!

How do I add Cities to States? (and when States are also Towns?)

So here’s the structure:

Parent: USA

Region (State/Town): Named States (50 of them).

Sub-region (City):  Fails.

Totally lost.

Chris

December 1, 2017
10:28 am
Chris
Member
Members
Forum Posts: 9
Member Since:
September 18, 2017
sp_UserOfflineSmall Offline

For anyone trying this, I did this page in reverse and was able to get cities attached to states:

https://awpcp.com/forum/faq/regions-module-configuration-tips/

I played around with localize, ended up with North America, then disabled Canada and kept USA.

Then I did something with Localize and was able to get the States (towns!)* I’d added to appear! Unsure how but now they’re in the Region Management Tools and Each state shows the the Region Parent is USA! Cool.

(North America shows no Region Parent and USA shows North America as the Region Parent)

Now I’m going to try and add lists of cities (and towns) to each of the 50 states.

*Note: In the part of the world I live in a Town is subordinate to a State–not equal to it, so it would be like Cities/Towns

December 1, 2017
2:50 pm
Chris
Member
Members
Forum Posts: 9
Member Since:
September 18, 2017
sp_UserOfflineSmall Offline

I guess I clicked the wrong button. I click into one state names I get this:

Fatal error: Call to undefined function ___() in /home/XXXXXXXXXX/public_html/wp-content/plugins/awpcp-region-control/awpcp_region_control_module.php on line 2129

December 1, 2017
3:16 pm
Chris
Member
Members
Forum Posts: 9
Member Since:
September 18, 2017
sp_UserOfflineSmall Offline

And now this fun:  The Regions table is a mile down the page:

 

vbAoNMJ.jpgImage Enlarger

December 3, 2017
5:33 pm
Jenni
Member
Members
Forum Posts: 8
Member Since:
November 21, 2017
sp_UserOfflineSmall Offline

I’m having problems with the region mod too.  I did manage to get some cities in there, but only the Lord knows how I actually got them to work.  But they are not showing the ads in that city so I’m posting about that. 

It would be great if the process could be explained a little better.  I have 49 more states to go and dreading every minute of it.

December 5, 2017
8:53 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 4738
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Chris,

I’m sorry you ran into issues with this as well. Can we please get WP admin and FTP credentials to your site to look into this further?

We need the following information to debug the issue:
– A link to this forum thread
– WP admin username
– WP admin password
– WP login URL
– FTP username
– FTP password
– FTP servername/IP address

Contact us with that information here: https://awpcp.com/contact/

Forum Timezone: America/Denver

Most Users Ever Online: 163

Currently Online:
7 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Johnny B: 140

godie: 120

kerdezo: 97

laburke: 94

NAIN KHAN: 93

salvig67: 84

rude: 72

purplepaula: 72

WAYTOBAYWTB52: 71

gery: 71

Member Stats:

Guest Posters: 28

Members: 37144

Moderators: 2

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 6682

Posts: 29955

Newest Members:

Micromedia, Lewis65, testuser990, Sagnik Roy, bibbo, falcore, Maxi, Wayne.S, Jobspringer, Test Tes

Moderators: awpcp: 7530, AWPCP Support: 4738

Administrators: wpengine: 0, awpcp: 298

Skip to toolbar