Ad deletion after expiry | Support Questions | Support Forum

A A A

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Ad deletion after expiry
March 28, 2019
9:45 am
Martin Stewart
Oban, Scotland
Member
Members
Forum Posts: 3
Member Since:
March 12, 2019
sp_UserOfflineSmall Offline

Hi, another question for you.

I'm looking to have ads automatically delete immediately after they expire. I've done some testing and it seemed to work fine when i had the deletion set to 2 days after expiry but since changing the duration to "0" days i'm finding that the ads do not automatically delete. 

I have "Disable expired listings instead of deleting them?" unchecked and "Number of days before expired listings are deleted" set to "0"

Are there any other factors that could stop an ad automatically deleting after it has expired?

I'm using AWPCP version: 3.9.5 and the AWPCP Fee Per Category Module. Wordpress version is 5.1.1.

Many thanks,

Martin

March 28, 2019
5:23 pm
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 5362
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Martin Stewart,

Thank you for posting. Sorry that you ran into issues with this!

I'm wondering if this is a fail-safe that was put in the plugin on purpose, and I will ask the developer to be sure. 

In the meantime, can you please do a check for theme and plugin conflicts to rule that out? Theme and plugin conflicts are very common in WordPress, and a conflict test is used to help determine the cause of the issue. Please conduct the test and let me know the results. Here is an article about how to test for theme and plugin conflicts with AWPCP, which may help pinpoint the issue: http://awpcp.com/forum/faq/how.....conflicts/

Also, what version of AWPCP Fee Per Category Module are you running?

That will help us troubleshoot the issue a little faster. Please let me know. 

March 29, 2019
5:07 am
Martin Stewart
Oban, Scotland
Member
Members
Forum Posts: 3
Member Since:
March 12, 2019
sp_UserOfflineSmall Offline

We're running AWPCP Fee Per Category Module 3.6.

I've deactivated all other plugins and started a few more test ads to see how they behave. I'll update the post as soon as i see what happens.

 

thanks,

Martin

April 3, 2019
9:39 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 5362
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Martin Stewart,

Thanks for your patience here.

I just heard back from the developer regarding the issue you reported, and here is what he said:
---------------------------------------

I tested this and it seems to work.  Setting it to 0 doesn't change anything right way, but the way it works is that first after the ad expires it is changed into the disabled state by a cron job that runs every hour. Then there is another cron job that runs daily looking for ads that have been disabled by the first cron job. It won't be immediately deleted after it expires but only once every day are disabled listings deleted. 

---------------------------------------

If things aren't working that way on your site, we may need more info from you. Please try that and let me know if you run into more issues.

Forum Timezone: America/Denver

Most Users Ever Online: 163

Currently Online:
15 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Johnny B: 140

godie: 120

kerdezo: 99

laburke: 94

NAIN KHAN: 93

salvig67: 84

sctpfwape: 75

rude: 72

purplepaula: 72

WAYTOBAYWTB52: 71

Member Stats:

Guest Posters: 32

Members: 38136

Moderators: 3

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 7036

Posts: 31284

Newest Members:

kurnailstop, motordkrental, nailsjuliitaxd, Mark, Rachael, SHERI, bhawanaconsultancy, alexlug, ludniko, Matakoi

Moderators: awpcp: 7530, AWPCP Support: 5362, Bobbie Devereux: 0

Administrators: wpengine: 0, awpcp: 300

Skip to toolbar