Search with region control module enabled. | Support Questions | Support Forum

A A A

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Search with region control module enabled.
January 10, 2017
11:51 pm
Stidsen
Member
Members
Forum Posts: 19
Member Since:
June 17, 2016
sp_UserOfflineSmall Offline

I have noticed a small issue with the search function, which also seems to be present on the AWPCP demo site.

I have logged into the demo site with my profile, making the default location on the front page to be set as Denmark.

  • Displaying listings from Denmark

Now, the add count in all categories shows zero, as there is no ads from Denmark. This is quite clear for everyone.

If I then go to the Search Ads page, the Country selector is by default set to “Select country. To me, this indicates that no country is selected and I will be searching in the entire database of ads.

I type in “car” as a key word and hit “Start search” – the result is “There were no listings found”. This is a bit strange as there is a lot of ads with the word “car”.

It seems like the search I performed was a search for ads from Denmark only (as set on the front page from my profile), however, this is not indicated anywhere in the search form or the search result.

If I actively choose USA as country and perform the same search for “car”, a lot of results show up.

 

Is there any way I can elliminate this issue on my web site, as some of my users are confused about the searches as no results shows up when they think they are searching all ads?

January 12, 2017
8:09 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 4332
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Stidsen,

We are sorry that you ran into this.

Which version of WP, AWPCP and Regions Control Module are you using?

Could you check for any conflict that might be causing this? You could follow the instructions here http://awpcp.com/forum/faq/how…..conflicts/

January 12, 2017
3:52 pm
Stidsen
Member
Members
Forum Posts: 19
Member Since:
June 17, 2016
sp_UserOfflineSmall Offline

On my own page I am using the newest version both WP, AWPCP and the Regions Control Module.

The issue is present at my setup, however, the test I described was done on the AWPCP Demo page at http://awpcp.com/classifieds/

It seems to be an issue in the plugin and not in my site.

January 13, 2017
5:54 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 4332
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Stidsen,

Could you send us the link to your site to reproduce the issue?

Could you send us some screenshots on how you did it through the demo site? I tried reproducing the issue but it looks fine on my end. I don’t see Denmark on the list of countries on the demo site as well https://www.screencast.com/t/YQtz4TvxBE

January 13, 2017
12:50 pm
Stidsen
Member
Members
Forum Posts: 19
Member Since:
June 17, 2016
sp_UserOfflineSmall Offline

At the AWPCP demo site:

 

https://www.screencast.com/t/1QQwGsQsdXs5

At the demo site, logged in, region is set from my profile.

 

https://www.screencast.com/t/aiRYivAwq5L

I go to the search page and type in “car” as key word. No country selected. I assume I am doing a world wide search.

 

https://www.screencast.com/t/efUqr0XP

The search result shows nothing. Again, I assume this is the result for a world wide search as nothing else is stated on the page.

 

https://www.screencast.com/t/MRGUx79FG

Back to the front page, now I have reset the region.

I then go to the search page again and do the same search as mentioned above.

 

https://www.screencast.com/t/pfKharUAd

This time, the search result is quite different.

 

On my own page, http://www.fuglemarkedet.dk the same issue is present. If a region is selected at the front page, or via the users profile, the search will automaticaly be for the ads in this region only without this is stated at the search page.

January 14, 2017
6:48 am
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 4332
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Stidsen,

The behavior you described is how search would function when Regions Control Module is enabled. However, we would need to make some changes to the search page to indicate the location where the search is being made to or shown on the search results. We will look into this enhancement when working on a future release.

January 21, 2017
1:14 pm
Stidsen
Member
Members
Forum Posts: 19
Member Since:
June 17, 2016
sp_UserOfflineSmall Offline

I think you should treat this as an error which needs to be fixed.

January 21, 2017
9:24 pm
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 4332
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Stidsen,

Yes, I’ve forwarded this to our developer already and had it checked.

January 24, 2017
12:00 pm
AWPCP Support
Moderator
Members

Moderators
Forum Posts: 4332
Member Since:
September 4, 2013
sp_UserOfflineSmall Offline

Hi Stidsen,

We’ve noted of this behavior and we will get it fixed on a future release.

Forum Timezone: America/Denver

Most Users Ever Online: 163

Currently Online:
23 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Johnny B: 140

godie: 120

laburke: 94

NAIN KHAN: 93

salvig67: 84

kerdezo: 74

rude: 72

purplepaula: 72

gery: 71

WAYTOBAYWTB52: 71

Member Stats:

Guest Posters: 27

Members: 36410

Moderators: 2

Admins: 2

Forum Stats:

Groups: 1

Forums: 4

Topics: 6405

Posts: 29000

Newest Members:

ufuk, Reyan, Vince, a, Conrad Lopez, Chandra De Maistre, Lawrence Barreiro, Lionel Keister, Lyda Simpkinson, Roland Corkill

Moderators: awpcp: 7530, AWPCP Support: 4332

Administrators: wpengine: 0, awpcp: 297

Skip to toolbar